[OpenAFS] AFS cache on ZFS fails

Jeffrey Hutzelman jhutz@cmu.edu
Fri, 21 Jul 2006 21:29:57 -0400

On Friday, July 21, 2006 08:45:51 PM -0400 William Yang <wyang@tjhsst.edu> 

> I suspect this is because of the way AFS cache space is handled by afsd.
> When I start afsd with AFS cache on ZFS I get a kernel panic, similar to
> the panic I get if I specify something under /tmp for cache (since /tmp
> is swap which includes RAM; it's not disk cache).  Does anyone know if
> support for AFS cache on a ZFS filesystem will eventually be implemented,
> or how I might be able to get it to work?  Also, while I haven't tried
> this yet, does anyone know if using ZFS for an AFS server partition
> works?  It'd be great if AFS worked with ZFS; performance should be
> greatly improved, plus we don't have HW RAID on our Solaris boxes so it
> would be great for reliability too.  Also, we wouldn't have to
> predetermine the partition sizes.

At present, storing the vice cache on ZFS is not yet supported.  This is 
likely to change in the future, but no specific timeline has been set.

The default fileserver on Solaris uses the inode backend, which does not 
currently support ZFS.  This may or may not change; in the meantime, the 
namei should work about as well as it always does.

-- Jeffrey T. Hutzelman (N3NHS) <jhutz+@cmu.edu>
   Sr. Research Systems Programmer
   School of Computer Science - Research Computing Facility
   Carnegie Mellon University - Pittsburgh, PA