[OpenAFS] AFS related problem with firefox

Juha Jäykkä juolja@utu.fi
Wed, 24 May 2006 09:08:20 +0300

Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Environment: Debian/Stable, openafs-client 1.3.81 (as distributed by
Debian), firefox 1.0.4 (again, as distributed by Debian in the stable
distribution). User's $HOME's are on AFS, binaries are (still) local.

Now, the following happens on one and only one machine. Starting firefox
takes the best part of the day. It blocks *all* AFS traffic while it's
starting, including its own: it gets stuck trying to close() (I ran
strace on it) files it reads and writes during startup. Eventually, it
will succeed, but only after having frozen the user's HOME for a
significant number of minutes first. Exporting HOME=3D/tmp, firefox starts
in a timely fashion without freezing anything. Thus I deem this is
somehow AFS related. On other machines, firefox works normally. Anyone
any pointers as to what to do?

There is one difference [1] between this and other machines, though: it is
running Debian pre-packaged kernel version 2.6.8-3-686, while the others
are 2.6.8-2-686. I haven't yet tried to go back to -2-686 to see if
-3-686 is to blame. I doubt, though, since it's supposed to be bugfixes
only and no other program seems to suffer.

[1] There are HW differences, of course, but there is even a machine with
identical HW sitting not two meters from the problematic machine. Both
have the same set of Debian packages installed and the same configuration.


		| Juha J=C3=A4ykk=C3=A4, juolja@utu.fi			|
		| home: http://www.utu.fi/~juolja/		|

Content-Type: application/pgp-signature; name=signature.asc
Content-Disposition: attachment; filename=signature.asc

Version: GnuPG v1.4.3 (GNU/Linux)