[OpenAFS] Re: [OpenAFS-devel] SOS: AFS instllation/Configuration

Derrick J Brashear shadow@dementia.org
Wed, 31 Jan 2007 07:15:21 -0500 (EST)

*Still* not a development issue. The code obviously works for lots of 
people. Pruned list this is sent to.

Anyway, what does ls -lR /usr/afs say?

On Wed, 31 Jan 2007, Srikanth Bhaskar wrote:

> Hi Marcus,
> Thanks a lot for the reply!
> I am referring to the documentation on the website. It does not speak about
> how to go ahead configuring after installing the rpms on Linux.
> ------------------------------
> Defining Cell Name and Membership for Server
> Processes<http://www.openafs.org/pages/doc/QuickStartUnix/auqbg002.htm#ToC_64>
> Now assign your cell's name. The chapter in the *IBM AFS Administration
> Guide* about cell configuration and administration issues discusses the
> important considerations, explains why changing the name is difficult, and
> outlines the restrictions on name format. Two of the most important
> restrictions are that the name cannot include uppercase letters or more than
> 64 characters.
> Use the *bos setcellname* command to assign the cell name. It creates two
> files:
>   - */usr/afs/etc/ThisCell*, which defines this machine's cell
>  membership
>  - */usr/afs/etc/CellServDB*, which lists the cell's database server
>  machines; the machine named on the command line is placed on the list
>  automatically
> *Note:* In the following and every instruction in this guide, for the
> machine name argument substitute the fully-qualified hostname (such as *
> fs1.abc.com*) of the machine you are installing. For the cell name argument
> substitute your cell's complete name (such as *abc.com*).
> Issue the *bos setcellname* command to set the cell name.
> # *cd /usr/afs/bin*
> # *./bos setcellname* <machine name> <cell name> *-noauth*
> ------------------------------
> I hand-edited the file as you mentioned stopping the bosserver. Even then, I
> get the same error. I hand-edited the file in /usr/afs/etc and
> /usr/vice/etc/ also.
> I was able to go through this point on AIX and Solaris. but on FC3, I am
> stuck at this point. Any other resources? Please suggest me..
> Thanks,
> Srikanth
> On 1/31/07, Marcus Watts <mdw@umich.edu> wrote:
>> Writes "Srikanth Bhaskar" <srikanth.bhaskar@gmail.com>:
>> > Message-ID: <f1d994890701310218n1c6dd420j9654e045ef9c651@mail.gmail.com>
>> > From: "Srikanth Bhaskar" <srikanth.bhaskar@gmail.com>
>> > To: openafs-devel@openafs.org, openafs-info@openafs.org
>> > Subject: [OpenAFS-devel] SOS: AFS instllation/Configuration
>> >
>> > Hi All Again!
>> >
>> > I have been trying to install/configure AFS since more than a week now.
>> I
>> > have tried it on Windows (2003), Linux (RHEL 3, FC3), Solaris (10) and
>> AIX(
>> > 5.3). I have been ending up with a different set of errors each time and
>> > everytime.
>> >
>> > I have downloaded the rpms for FC3 and have installed the rpms. I see
>> that
>> > all the binaries and the config related files exist in their paths. But
>> now,
>> > when I try to set the cell, I end up with this error:
>> >
>> > [root@bri6506-5-fc3-1 etc]# ls
>> > CellServDB  ThisCell
>> > [root@bri6506-5-fc3-1 etc]# /usr/bin/bos setcellname bri6506-5-fc3-1
>> > afs.ca.com -noauth
>> > bos: failed to set cell (could not find entry)
>> >
>> > Could anyone please help me with the correct steps after installing the
>> rpms
>> > for FC3?
>> > Many Thanks,
>> What instructions were you following?
>> Where did you look to find instructions?  Perhaps we can arrange
>> to have better instructions in those places for those who follow
>> you.
>> You don't note what you have in "CellServDB" (or ThisCell), but an empty
>> server list would likely produce the error you saw.  Don't do that; your
>> only recourse at that point is to stop bosserver and hand-edit CellServDB
>> to
>> make it right.  This is probably what you should be doing in the first
>> place.
>> The instructions I use are here:
>>        /afs/umich.edu/user/m/d/mdw/wp/uniq.2k
>>                (later version, local paths)
>>        /afs/umich.edu/user/m/d/mdw/wp/uniq.2z
>>                (earlier version, with notes on possible RH paths)
>> If you can't read afs, try
>>        http://www.umich.edu/~mdw/uniq.2k
>>        http://www.umich.edu/~mdw/uniq.2z
>> the process described there is very much like what's automated in
>> Sam Hartman's(?) debian install process.  It avoids the need to use
>> "-noauth" and starts right off with Kerberos 5.  If you are successful
>> with those instructions (or not), you should let people know.  Since
>> they aren't the official instructions, they probably describe some
>> things better and some things worse.  If you don't have writable afs
>> space elsewhere, you will have to be a bit creative with the last part
>> of these instructions (ie, you'll have to bring up a separate dedicated
>> client at exactly the right point and with the correct configuration to
>> mount your newly minted root volume.)  These instructions should give
>> you "real" afs space for /afs/ - this is different from what you would
>> get if you run afsd with "-dynroot", which you apparently won't know
>> about if you're reading afsd man pages, but which Derrick is expecting
>> you would have used.  If you do choose to use "-dynroot", you will need
>> to set up DNS afsdb records which will likely constrain if not dictate
>> your choice for cell name.
>>                                -Marcus Watts
>> _______________________________________________
>> OpenAFS-devel mailing list
>> OpenAFS-devel@openafs.org
>> https://lists.openafs.org/mailman/listinfo/openafs-devel
> -- 
> Regards,
> Srikanth Bhaskar
> Hyderabad
> +91 9866649917
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> They may forget wat you said,
> but  they will never forget how you made them feel..