[OpenAFS] Protection database already exists

Matt Chipman matt@kaam.dyndns.org
Tue, 15 May 2007 17:12:25 +1000


I am really struggling with this error below.  Using Debian etch 
(stable) and openafs debs.  Have setup the server and associated apps 
according to the readme.servers in the doc directory also followed the 
install transcript in the same.

I have install the test server 3 times and am getting the same error 
each time.  Deleting the database does not remove the error and just 
recreates the database files while returning the same error.

what am I missing?




Do you meet these requirements? [y/n] y
If the fileserver is not running, this may hang for 30 seconds.
/etc/init.d/openafs-fileserver stop
Stopping AFS Server: bosserver.
What administrative principal should be used? matt/admin

/etc/openafs/server/CellServDB already exists, renaming to .old
/etc/init.d/openafs-fileserver start
Starting AFS Server: bosserver.
bos adduser fileserver.xxxxx.com matt.admin -localauth
ERROR: Protection database already exists; cell already partially
ERROR: created.   If you do not want the current database, remove
ERROR: all files in /var/lib/openafs/db and then run this program
ERROR: again.

Cell setup failed, ABORTING
bos removeuser fileserver.xxxxx.com matt.admin -localauth