[OpenAFS] Protection database already exists

Christian Kuka ckuka@madkooky.de
Tue, 15 May 2007 09:54:20 +0200

Content-Type: text/plain; charset=utf-8
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

maybe try to add the user without the perl script,

:bos adduser fileserver.xxxx.com matt.admin -noauth

or replace line 205 with something that removes the database if it

Thus wrote Matt Chipman (matt@kaam.dyndns.org) [07.05.15 09:20]:
> Hi,
> I am really struggling with this error below.  Using Debian etch=20
> (stable) and openafs debs.  Have setup the server and associated apps=20
> according to the readme.servers in the doc directory also followed the=20
> install transcript in the same.
> I have install the test server 3 times and am getting the same error=20
> each time.  Deleting the database does not remove the error and just=20
> recreates the database files while returning the same error.
> what am I missing?
> thanks
> -Matt
> afs-newcell
> Do you meet these requirements? [y/n] y
> If the fileserver is not running, this may hang for 30 seconds.
> /etc/init.d/openafs-fileserver stop
> Stopping AFS Server: bosserver.
> What administrative principal should be used? matt/admin
> /etc/openafs/server/CellServDB already exists, renaming to .old
> /etc/init.d/openafs-fileserver start
> Starting AFS Server: bosserver.
> bos adduser fileserver.xxxxx.com matt.admin -localauth
> ERROR: Protection database already exists; cell already partially
> ERROR: created.   If you do not want the current database, remove
> ERROR: all files in /var/lib/openafs/db and then run this program
> ERROR: again.
> Cell setup failed, ABORTING
> bos removeuser fileserver.xxxxx.com matt.admin -localauth
> _______________________________________________
> OpenAFS-info mailing list
> OpenAFS-info@openafs.org
> https://lists.openafs.org/mailman/listinfo/openafs-info

Christian Kuka

Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

Version: GnuPG v1.4.6 (GNU/Linux)