[OpenAFS] issue with Fedora 8 and retaining tokens after graphical login

Andrew Cobaugh phalenor@gmail.com
Sat, 24 Nov 2007 10:02:47 -0500

In the past (up until Fedora 8), afs has always Just Worked. The
supplied pam_krb5 was able to obtain a tgt and tokens, both with sshd
and when logging in through things like gdm.

I recently upgraded from 7 to 8. Logging in through sshd works
perfectly, but gdm stopped working. I get a tgt, but not tokens. Odd
thing is if I set pam_krb5 to debug in /etc/pam.d/system-auth, I get
all kinds of debug messages in /var/log/secure as expected when going
in through ssh, but I get none of this with gdm, so it's almost as if
gdm is skipping over pam, which doesn't make sense.

So, has anyone had trouble with Fedora 8 and afs in this respect? I've
downgraded to the pam_krb5 from Fedora 7 (pam_krb5-2.2.11-1), and that
hasn't fixed it. I suspect either something with gdm, or something
weird they're doing because of all of this ConsoleKit stuff...


Andy Cobaugh