[OpenAFS] issue with Fedora 8 and retaining tokens after graphical login

William Murray W.J.Murray@rl.ac.uk
Sat, 24 Nov 2007 16:27:24 +0000

  Hi Andrew,
         'afs has just worked?' with previous fedora? Well...I'd say
Fedora has been on latest kernels and AFS is struggling to keep up.
   However, using openafs-client from atrpms it seems to be pretty good
with f8. At least at work..
  unfortunately, at home, via a tunnel and NAT etc, it doesn't seem

On Sat, 2007-11-24 at 10:02 -0500, Andrew Cobaugh wrote:
> In the past (up until Fedora 8), afs has always Just Worked. The
> supplied pam_krb5 was able to obtain a tgt and tokens, both with sshd
> and when logging in through things like gdm.
> I recently upgraded from 7 to 8. Logging in through sshd works
> perfectly, but gdm stopped working. I get a tgt, but not tokens. Odd
> thing is if I set pam_krb5 to debug in /etc/pam.d/system-auth, I get
> all kinds of debug messages in /var/log/secure as expected when going
> in through ssh, but I get none of this with gdm, so it's almost as if
> gdm is skipping over pam, which doesn't make sense.
> So, has anyone had trouble with Fedora 8 and afs in this respect? I've
> downgraded to the pam_krb5 from Fedora 7 (pam_krb5-2.2.11-1), and that
> hasn't fixed it. I suspect either something with gdm, or something
> weird they're doing because of all of this ConsoleKit stuff...
> Ideas?