[OpenAFS] AFS share not writable

Michael Richter m.richter@tu-berlin.de
Tue, 28 Jun 2011 13:11:13 +0200

Hi List,

I have a problem on one computer. It's a Windows 7 Professional x64 and 
we're using integrated login. I tried this with OpenAFS 1.5.78 and The user can login normaly. The Windows profile is loaded from 
AFS and his AFS home drive is mounted on Z:.

The problem is, the user has readonly access. If we try to create a 
file/dir or save a existing file it doesn't work. If we try to create a 
file/dir in Z:\ nothing happens (even no error message). If we try the 
same in a subdir we get the error message "Too many files opened for 

I can disconnect this drive and reconnect via "net use" or Windows 
Explorer but we can still not write on it. But I can reconnect it using 
AFS control panel (Global Drives). This way I get normal access to the 
afs share. The user has normal access rights and more than 200 MB left 
and it works using AFS control panel. But this way he would need to 
click everytime through the dialogs to reconnect the drive.

Does someone know where the problem is? On every other machine we don't 
have this problem.

Michael Richter