[OpenAFS] AFS share not writable

Lars Schimmer l.schimmer@cgv.tugraz.at
Tue, 28 Jun 2011 13:47:08 +0200

On 2011-06-28 13:11, Michael Richter wrote:
> Hi List,
> I have a problem on one computer. It's a Windows 7 Professional x64 and
> we're using integrated login. I tried this with OpenAFS 1.5.78 and
> The user can login normaly. The Windows profile is loaded fro=
> AFS and his AFS home drive is mounted on Z:.

How is it mounted?
Do use "map network drive" and not the OpenAFS function.

> The problem is, the user has readonly access. If we try to create a
> file/dir or save a existing file it doesn't work. If we try to create a
> file/dir in Z:\ nothing happens (even no error message). If we try the
> same in a subdir we get the error message "Too many files opened for
> sharing".

Something is bad. Is it a RW volume?

> I can disconnect this drive and reconnect via "net use" or Windows
> Explorer but we can still not write on it. But I can reconnect it using
> AFS control panel (Global Drives). This way I get normal access to the
> afs share. The user has normal access rights and more than 200 MB left
> and it works using AFS control panel. But this way he would need to
> click everytime through the dialogs to reconnect the drive.

Do not use Global Drives mounting, it is buggy and does not work.

> Does someone know where the problem is? On every other machine we don't
> have this problem.
> Thanks
> Michael Richter

Lars Schimmer
TU Graz, Institut f=FCr ComputerGraphik & WissensVisualisierung
Tel: +43 316 873-5405       E-Mail: l.schimmer@cgv.tugraz.at
Fax: +43 316 873-5402       PGP-Key-ID: 0x4A9B1723