[OpenAFS] AFS share not writable

Michael Richter m.richter@tu-berlin.de
Tue, 28 Jun 2011 14:15:30 +0200

Lars Schimmer schrieb am Tue, 28.06.2011 um 13:47:
> On 2011-06-28 13:11, Michael Richter wrote:
>> Hi List,
>> I have a problem on one computer. It's a Windows 7 Professional x64 and
>> we're using integrated login. I tried this with OpenAFS 1.5.78 and
>> The user can login normaly. The Windows profile is loaded from
>> AFS and his AFS home drive is mounted on Z:.
> How is it mounted?
> Do use "map network drive" and not the OpenAFS function.


>> The problem is, the user has readonly access. If we try to create a
>> file/dir or save a existing file it doesn't work. If we try to create a
>> file/dir in Z:\ nothing happens (even no error message). If we try the
>> same in a subdir we get the error message "Too many files opened for
>> sharing".
> Something is bad. Is it a RW volume?

Jep, on other computers the user can read and write on his afs drive. 
And with the global drive via AFS control panel it works too. And every 
user has this problem on this computer, so I think it's not a problem 
with the server side.

>> I can disconnect this drive and reconnect via "net use" or Windows
>> Explorer but we can still not write on it. But I can reconnect it using
>> AFS control panel (Global Drives). This way I get normal access to the
>> afs share. The user has normal access rights and more than 200 MB left
>> and it works using AFS control panel. But this way he would need to
>> click everytime through the dialogs to reconnect the drive.
> Do not use Global Drives mounting, it is buggy and does not work.

We noticed that AFS remembers the submounts but does not show them. So 
we have to take a new one everytime. But this is actually the only way 
to get full write access to his afs drive.

>> Does someone know where the problem is? On every other machine we don't
>> have this problem.
>> Thanks
>> Michael Richter
> MfG,
> Lars Schimmer