[OpenAFS] Re: Volser: GetVolInfo: Could not attach volume (/vicepa:) error=101

Dan Scott danieljamesscott@gmail.com
Mon, 30 Jan 2012 15:22:34 -0500

On Mon, Jan 30, 2012 at 15:00, Andrew Deason <adeason@sinenomine.net> wrote:
> On Mon, 30 Jan 2012 14:44:58 -0500
> Dan Scott <danieljamesscott@gmail.com> wrote:
>> > How specifically are they not accessible? How are you trying to
>> > access them, and what error do you get? If you are trying to access
>> > files in the volume from a client, the FileLog may say something
>> > about the volume.
>> All of the volumes under a particular mount point give:
>> djscott@pc35:~$ ls /afs/example.com/volume
>> ls: cannot access /afs/example.com/volume: No such device
>> Other volumes on other servers are fine. I just ran the salvager which
>> fixed a load of problems, but still no luck.
> Do FileLog or SalvageLog mention that volume? (either by id number or by
> name)

FileLog doesn't. The last entry just shows:

Mon Jan 30 15:06:08 2012 File Server started Mon Jan 30 15:06:08 2012

The SalvageLog shows salvage entries for all volumes on the partition
(including the one which gave an error):

01/30/2012 15:05:49 m2.bi.rde.2011.micu (1669173317) updated 01/03/2012 14:42
01/30/2012 15:05:49 totalInodes 189436
01/30/2012 15:05:52 Salvaged m2.bi.rde.2011.micu (1669173317): 189432
files, 184649148 blocks
01/30/2012 15:05:52 SALVAGING OF PARTITION /vicepa COMPLETED

The error message I mentioned initially has now stopped, but the
server still doesn't appear to be working properly.

> Also try running 'fs checks', 'fs checkv', and
> 'fs flushm /afs/example.com/volume' on the client, and see if that makes
> any difference.

djscott@pc35:~$ fs checks
All servers are running.
djscott@pc35:~$ fs checkv
All volumeID/name mappings checked.

The flushm didn't help. Still saying 'No such device'.