[OpenAFS] some older openafs-client versions have started failing

Chad William Seys cwseys@physics.wisc.edu
Thu, 14 Jul 2016 14:55:49 -0500

Hi all,
	We have begun suddenly begun experiencing client failures and are trying 
to determine what is going on.

openafs-client versions 1.6.9, 1.6.14, 1.6.15 fail in various ways*.  On 
Debian we can reproduce the problem by 'git checkout' a particular repo. It 
fails with a "Connection timed out".  On Scientific Linux the problem 
manifests sooner: 'ls /afs/ANYCELL' hangs.  

openafs-client 1.6.16, 1.6.17, seem to work normally.

I've tried changing the server's fileserver version but that has no effect.  
(Tried Debian packages with versions 1.6.1-3+deb7u6, 1.6.9+deb8u5, and .)

We started noticing this problem after a power failure.  We think what 
happened was that new fileserver code started being used after the servers 
rebooted.  Probably fileserver code changed from Debian 1.6.1-3+deb7u5 to 
1.6.1-3+deb7u6 .  Strangely though reverting back to what we think were the 
working versions also does not work.

Anyone have an idea of what might be going on ?


* These version numbers were determined with a mix of Debian packages, 
Scientific Linux packages, and straight from openafs.org source rpms.  Let me 
know if that is important.