[OpenAFS-devel] rx abort bug?

Neulinger, Nathan nneul@umr.edu
Wed, 20 Oct 2004 11:04:27 -0500

I've brought something like this up in the past, seen randomly, and
what's really ugly about it in my case, is that the fileserver (at least
what I've seen) will never talk to the client again... even with new
tokens, flushes, etc. Rebooting client fixes problem though.=20

-- Nathan

Nathan Neulinger                       EMail:  nneul@umr.edu
University of Missouri - Rolla         Phone: (573) 341-6679
UMR Information Technology             Fax: (573) 341-4216

> -----Original Message-----
> From: openafs-devel-admin@openafs.org=20
> [mailto:openafs-devel-admin@openafs.org] On Behalf Of Jim Rees
> Sent: Wednesday, October 20, 2004 10:40 AM
> To: openafs-devel@openafs.org
> Subject: [OpenAFS-devel] rx abort bug?
> I'm running a client that's about a month old, built from cvs=20
> head.  I had
> tokens, then I threw them away with kdestroy.  Next time I=20
> tried to talk to
> the file server, the client apparently tried to re-use the rx=20
> connection,
> because it sent an encrypted fs request.  The server sent=20
> back an rx abort
> with code RXKAD_EXPIRED.
> At this point, the client retried the call in the same way. =20
> Shouldn't it
> have closed the connection and opened a new, unauthenticated=20
> one?  Or should
> the server have sent an rx challenge?  Is this a known bug?
> I have no way to reproduce this.
> _______________________________________________
> OpenAFS-devel mailing list
> OpenAFS-devel@openafs.org
> https://lists.openafs.org/mailman/listinfo/openafs-devel