[OpenAFS-devel] rx abort bug?

Derrick J Brashear shadow@dementia.org
Mon, 25 Oct 2004 15:45:29 -0400 (EDT)

On Sat, 23 Oct 2004, Derrick J Brashear wrote:

>> I'm running a client that's about a month old, built from cvs head.  I had
>> tokens, then I threw them away with kdestroy.  Next time I tried to talk to
>> the file server, the client apparently tried to re-use the rx connection,
>> because it sent an encrypted fs request.  The server sent back an rx abort
>> with code RXKAD_EXPIRED.
>> At this point, the client retried the call in the same way.  Shouldn't it
>> have closed the connection and opened a new, unauthenticated one?  Or 
>> should
>> the server have sent an rx challenge?  Is this a known bug?
> I've seen it twice. I also lack the way to reproduce it, after I handle a few 
> other things this is one of 2 issues I mean to go back and look at (the other 
> is 
> http://grand.central.org/rt/Ticket/Display.html?id=15726&user=guest&pass=guest
> )

Actually, this would imply afs_Analyze is broken, I think.