[OpenAFS] Problem with installing

Tufan řen tufan@itu.edu.tr
Tue, 15 May 2001 11:17:53 +0300


I compiled openafs-1.0.4 at my RedHat 7.1 box. When I tried to install , I
got the following error. Any idea?

[root@seawolf openafs-1.0.4]# make SYS_NAME="i386_linux24"
LINUX_VERS="2.4.2" install
make finale "SYS_NAME=i386_linux24" "WASHTOOL=dest/bin/washtool" \
        "COMPILE_PART1=dest/bin/washtool make" \
        "COMPILE_PART2=-argument install" \
         DESTDIR=`pwd`/i386_linux24/dest/ \
         SRCDIR=`pwd`/i386_linux24/dest/ \
         "DBG_DEFS="
make[1]: Entering directory `/root/openafs-1.0.4'
if test -f "dest/bin/washtool"; \
 then \
        dest/bin/washtool project . . -noretarget; \
        dest/bin/washtool destdir; \
fi
dest/bin/washtool make config -argument install
make[1]: dest/bin/washtool: Command not found
make[1]: *** [config] Error 127
make[1]: Leaving directory `/root/openafs-1.0.4'
make: *** [install] Error 2

Then I used the RPMS for RedHat 7.1.
When I try to start afs with "/etc/rc.d/init.d/afs start" I got an error
about the kernel module. I fixed it by copying the kernel module with the
correct name. (I added smp to the module name.) Then everything worked fine
until I tried to write a file.

I tried "echo 1 >x ". The prosses didn't work and I could not kill it. ( I
tried to kill it with signal 9 but no hope.) Doea anyone experienced
something like this.

PS: I used "Quick Beginnings" guide.

Thanks...

řeref Tufan řen
ITU-BIDB
Sistem Destek Grubu