[OpenAFS] Problem with installing

Tufan Sen tufan@itu.edu.tr
Fri, 18 May 2001 12:45:53 +0300

> > Then I used the RPMS for RedHat 7.1.
> > When I try to start afs with "/etc/rc.d/init.d/afs start" I
> got an error
> > about the kernel module. I fixed it by copying the kernel
> module with the
> > correct name. (I added smp to the module name.) Then
> everything worked fine
> > until I tried to write a file.
> This is not a fix. a non-smp module is correctly named for use on a
> non-smp system, and won't work on an smp system. You'll need
> to compile a
> module for your system, and there are reports it won't work with the
> Redhat kernel in the SMP case, which I haven't verified.
> OpenAFS 1.0.4 is
> known to work on a 2.4.4 SMP (4 processor) system with a non-Alan-Cox
> kernel.

I tried to compile the kernel modules from openafs-kernel-source rpm for RH
7.1. I got the following error. "redhat.sh" is missing. Where can I get it?
Or is there another way to compile the kernel modules ? Thanks for your

[root@seawolf openafs-kernel-1.0.4]# make build-it
cd src; make all LINUX_SRCDIR=/usr/src/linux-`uname -r`
LINUX_VERS=`uname -r`
make[1]: Entering directory `/usr/src/openafs-kernel-1.0.4/src'
Makefile:167: warning: overriding commands for target `xdr_int64.o'
Makefile.common:234: warning: ignoring old commands for target `xdr_int64.o'
rm -f h net netinet sys rpc
ln -s rx rpc
for v in 2.4.2-2smp ; do \
        for m in MP SP ; do \
                KDIR=MODLOAD-$v-$m; \
                mkdir -p ${KDIR}; \
                ln -fs ../Makefile ${KDIR}/Makefile ; \
                ln -fs ../Makefile.common ${KDIR}/Makefile.common; \
                sh ./redhat.sh /usr/src/linux-2.4.2-2smp$v
${KDIR}/Makefile.extradefs; \
        done \
./redhat.sh: ./redhat.sh: No such file or directory
./redhat.sh: ./redhat.sh: No such file or directory
make[1]: *** [setup] Error 127
make[1]: Leaving directory `/usr/src/openafs-kernel-1.0.4/src'
make: *** [src/COMMON/libafs.o] Error 2