[OpenAFS] no quorom elected again

J S vervoom@hotmail.com
Fri, 30 Apr 2004 12:29:42 +0000

>On 4/30/2004 07:16, J S wrote:
>>I get the "no quorom elected" error when trying to create or move a volume 
>>on a new partition vicpe, I've just created.
>This means that the vlserver is running, but not happy with the condition 
>of its peers on other servers.
>># rxdebug -servers localhost -version
>>Trying (port 7000):
>>AFS version: Base configuration afs3.5 3.60
>This is an incredibly ancient file server!  Transarc AFS version 3.5 (3.60 
>is the configuration number).  I am pretty sure that AFS 3.6 was the basis 
>for OpenAFS, so this server binary has to be 5 years old.  Can that be 
>On the other hand there isn't any reason to think that no quorom problems 
>are caused by this.  It is just amazing.
> > I've checked the config files and they look OK too. Is there anything
> > else I can try?
>The key information would be the contents of your server's CellServDB so 
>you can tell what database servers you have in your cell.  Each of these 
>servers needs the same CellServDB (the server side file in /usr/afs/etc) so 
>that all database servers know about the same set of peers.  Check that all 
>those servers are running vlservers.
>If all that is working, then you should run udebug on each server 
>specifying the port of the vlserver.  Google[1] reminds me that this is 
>port 7003.  Interpreting the udebug output is pretty arcane, but there are 
>some web pages that explain it.  One easy thing to check for is clock skew. 
>  The vlservers need to have the same clocks within a few seconds; those 
>machines should all be running ntp[2].
>Ted Anderson

Thanks Ted,

I tried the udebug cmd and found that the vlserver wasn't running on the AFS 
server. It wasn't in the BosConfig so I added it in and started it up. I 
stil got the quorum error after that (but much faster) so tried a bos 
restart -all and now I get this message:

# vos move -id logs.proxy -fromserver cspc1n11e -frompartition /vicepa 
-toserver localhost -topartition /vicepe
Failed to create transaction on the volume 536871060
   VOLSER: permission denied, not a super user
vos move: operation interrupted, cleanup in progress...
clear transaction contexts
move incomplete - attempt cleanup of target partition - no guarantee
cleanup complete - user verify desired result

I'm logged on the box as root, and I'm logged in as the AFS administrator so 
not sure why it's saying 'not a super user'


Express yourself with cool emoticons - download MSN Messenger today!