[OpenAFS] Re: Possible cache corruption with linux client and 1.6.1 fileserver

Andrew Deason adeason@sinenomine.net
Fri, 16 Nov 2012 10:35:43 -0600

On Thu, 15 Nov 2012 22:30:15 -0500
Marc Dionne <marc.c.dionne@gmail.com> wrote:

> > This problem I believe was introduced with Linux commit
> > a32ea1e1f925399e0d81ca3f7394a44a6dafa12c, which is in 2.6.22. That
> > was included in RHEL5 in 2.6.18-128.el5, or at least sometime
> > between 2.6.18-92.1.27.el5 and 2.6.18-128.el5. I'm not completely
> > sure if that's what actually caused this (I haven't tried to
> > reproduce this on an older kernel yet), but it looks like it.
> I've been able to reproduce this on a current kernel, and replacing
> one of the key parts of that Linux commit (a32ea1e1f925) makes the
> problem go away.  So I think you definitely pinpointed the right
> change on the Linux side.

Thanks! I also tried with 2.6.18-92.1.27.el5, and couldn't get it to
happen. It's a bit harder to find out about SLES... since that patch
came from suse, I assume it was included for them around that time, but
I'm not sure when.

Andrew Deason